Setting up spacing to avoid "crowded measures"

The place for beginner Finale users. ("How do I...")

Moderators: miker, Peter Thomsen

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Sun Sep 06, 2020 3:17 am

Glad it worked.

Even three 8ths in the place of 1 quarter is messed up--it tosses in an extra rest as you enter the notes replacing the rests.

Re: Re: Setting up spacing to avoid "crowded measures"

by Sponsor

Forum Sponsor
 

User avatar
zuill
Posts: 3352
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.3.1
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by zuill » Sun Sep 06, 2020 4:16 am

I left the 15 tuplet as is with no problem. No bug. That was in the original file, where the issue was in a 5/4 bar. This new one has a 4/4 bar. Needless to say I'm confused about what is needed.

Zuill
Windows 10, Finale 2011-v26.3.1
"When all is said and done, more is said than done."

User avatar
zuill
Posts: 3352
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.3.1
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by zuill » Sun Sep 06, 2020 4:36 am

bj nick wrote:
Sat Sep 05, 2020 11:09 pm
Thank you, Zuill, but when I paste it into the score, you'll see what I get. Btw I tried pasting it right over, then tried erasing the bar, then pasting it, same result both times. I attached the result.
This score has the 5 group in a 4/4 bar. The original was in a 5/4 bar. Which do you want?

Zuill
Windows 10, Finale 2011-v26.3.1
"When all is said and done, more is said than done."

bj nick
Posts: 111
Joined: Wed Mar 21, 2007 4:10 am

Re: Setting up spacing to avoid "crowded measures"

Post by bj nick » Sun Sep 06, 2020 5:02 am

It's working now I'm good. Thanks to you. Thank you very much. For the record, obviously I've used triplets, three eighth notes to a quarter note - - a million times without any problem. So not sure what you mean.

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Sun Sep 06, 2020 5:23 am

I entered the first eighth note of a triplet, then with Alt+9 set up "3 eighths in the space of 1 quarter." After completing the triplet, I was left with a stray rest:
0669.png
I then skipped past this rest with the arrow key, entered an eighth note and a quarter note. So far, so good.
0667.png
But when entering the final quarter note, I'm treated to this:
0668.png
Pretty wild!

I believe the shortest note is 1 EDU long, a 4096th note, I think. If you look at the measure with Edit Frame, you'll find all sorts of short notes.

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Sun Sep 06, 2020 5:43 am

If you first delete the rests created by the tuplet dialog, the problem doesn't happen. But I recall other instances where if you delete the rests, especially if the tupet is at the end of the measure, mischief of a different sort ensues. Can anyone clear this up?

So I've always advised people not to delete the rests, which apparently got bj nick here in trouble, for which I apologize. I remain confused by it, and am glad I'm mainly a Speedy entry user.

It seems like it would be an easy matter for MM to fix this, but I don't see it happening.

User avatar
zuill
Posts: 3352
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.3.1
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by zuill » Sun Sep 06, 2020 5:43 am

Try this. Do what you describe except stop before entering the last Quarter (fill with rests should be turned off). Go into the Speedy Edit frame and see what the value is of that 8th rest. Instead of 512, it is 683. If you manually change it to 512, then you can enter the last quarter note.

Zuill
Windows 10, Finale 2011-v26.3.1
"When all is said and done, more is said than done."

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Sun Sep 06, 2020 4:12 pm

Thanks for the sleuthing. 683 is a third of a half note--the combined value of those eighth rests the tuplet dialog creates?. Finale normally never stores such values, instead using only powers of 2 and a tuplet flag (pointing to some other structure describing the tuplet, I'm assuming).

Creating the tuplet both ways and looking at the edit frame, they are identical. So the bug seems to happen when you replace those rests. Mouse entry seems OK. Both QWERTY and MIDI input invoke the bug.

User avatar
zuill
Posts: 3352
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.3.1
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by zuill » Sun Sep 06, 2020 7:33 pm

When the second note is entered, the extra rest appears. Once you enter the third note, then delete the extra rest. I know you shouldn't have to. I submitted a ticket to MM with a file documenting the steps to the problem and details about how to see the odd value assigned to the 8th rest. Hopefully they'll investigate. They seem to take my reports seriously, probably because they know my reputation for dogging them until it gets fixed. I can't say for this problem, but hopefully they'll at least acknowledge it, and maybe put a warning about it on their FAQ page.

Zuill
Windows 10, Finale 2011-v26.3.1
"When all is said and done, more is said than done."

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Sun Sep 06, 2020 7:53 pm

Thanks for reporting it. I'm guessing the average MM support person doesn' t know from Edit Frame, but hopefully they'll log it and perhaps a future owner will fix it.

There are easy work-arounds, of course; worse, it trips up the unsuspecting.

bj nick
Posts: 111
Joined: Wed Mar 21, 2007 4:10 am

Re: Setting up spacing to avoid "crowded measures"

Post by bj nick » Sun Sep 06, 2020 8:50 pm

I LOVE that bar! I'd love to put that in front of a top-flight studio or symphony musician and pretend it's a real part. Tell them "Look, please don't screw up any of the tied notes.....it's really important that you strictly observe ALL of them."

bj nick
Posts: 111
Joined: Wed Mar 21, 2007 4:10 am

Re: Setting up spacing to avoid "crowded measures"

Post by bj nick » Sun Sep 06, 2020 8:51 pm

For the record: I appreciate all these efforts but the elaborate work-around is beyond my limited musical/emotional capacity to absorb.....I'll just try to keep things simple. And not get frustrated if I get insane weirdness.

User avatar
zuill
Posts: 3352
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.3.1
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by zuill » Wed Sep 16, 2020 10:13 pm

motet wrote:
Sun Sep 06, 2020 7:53 pm
Thanks for reporting it. I'm guessing the average MM support person doesn' t know from Edit Frame, but hopefully they'll log it and perhaps a future owner will fix it.

There are easy work-arounds, of course; worse, it trips up the unsuspecting.
I just got a reply from MM saying there is no bug. They sent me a video showing what they did to not get a bug. The entered an 8th note, then hit alt-9. It showed 3 current duration in place of 2 current duration. They then proceeded and showed no bug. I can also get that correct behavior. However, the file I sent gave very specific directions to choose 3 8ths in place of 1 quarter. They ignored that instruction, thus no bug.

Motet: did you understand the instructions in the same file I sent them that I posted here? And, like you said, they didn't even mention the Speedy Edit Frame. You may be right that they might not even know what that is.

Zuill
Windows 10, Finale 2011-v26.3.1
"When all is said and done, more is said than done."

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Wed Sep 16, 2020 10:23 pm

zuill wrote:
Wed Sep 16, 2020 10:13 pm
Motet: did you understand the instructions in the same file I sent them that I posted here?
Thanks for reporting it and for reporting back here.

I'm not sure what you're asking. I never tried fixing the rest by editing the frame, but I'm sure it works.

If you have the stomach to write back, I would emphasize the three eighths in the space of one quarter, which leads to the outrageous result shown above. No need to mention Edit Frame, I don't think.

I think their goal is always to get rid of you if there's a work-around. If there's no problem with "3 in the space of 2," then there's no problem, by their line of thinking. But that doesn't help the unsuspecting user who uses "in the space of 1 quarter," of course.

User avatar
zuill
Posts: 3352
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.3.1
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by zuill » Wed Sep 16, 2020 10:29 pm

You reported that when you looked in the Edit frame, the value for the 8th note after the erroneous quarter rest had an unusual value of 683. I just re-read your post. They didn't even acknowledge that they checked the Speedy Edit Frame. I really think that they didn't read all the detail I was careful to include in my file. Here's the file again for anyone else who would like to test my steps to a T.

Zuill

P.S.: Not only did I have the stomach to write back, I included my cell number so they could call me so I could walk them through the steps one by one.
Windows 10, Finale 2011-v26.3.1
"When all is said and done, more is said than done."

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Thu Sep 17, 2020 1:21 am

I see. Well, this should get their attention even without looking at the frame. Thanks for persisting.

User avatar
zuill
Posts: 3352
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.3.1
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by zuill » Thu Sep 17, 2020 3:19 am

What do you know? I tried other 3:1 tuplets (3 quarters to 1 half, 3 16ths to 1 eighth) with similar bad behavior. Checking in the Speedy Edit Frame shows similar odd numerical value for the "extra" note. I tested this back to finale 2011. All versions have the same bad behavior.

This is a unique behavior to Simple Entry, because of the way it adds those extra rests. That must be the trigger. Setting up Tuplets in Speedy and with the Tuplet Tool don't add those rests. We know now we can get rid of the extra rest, but I don't thing the designers wanted the wonkiness. I don't think they even know about it. And my attempt to alert them to it seems to be landing on deaf ears.

Zuill
Windows 10, Finale 2011-v26.3.1
"When all is said and done, more is said than done."

User avatar
zuill
Posts: 3352
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.3.1
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by zuill » Thu Sep 17, 2020 3:57 am

I've heard back from MakeMusic. They followed my steps and now confirm the bug. I'm the proverbial squeaky wheel. I also gave more details about my further testing. Hopefully they might be able to fix this.

Zuill
Windows 10, Finale 2011-v26.3.1
"When all is said and done, more is said than done."

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Thu Sep 17, 2020 4:35 am

Squeak on, brother!

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Thu Sep 17, 2020 4:54 am

In this case, it's good to delete the rests before fleshing out the tuplet. In other cases, just the opposite is true, if I'm remembering correctly--delete the rests, and a problem ensues. If they really are saying they'll fix this one, that one might be worth reporting to, if someone can remember what it was (end of the bar?).

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Thu Sep 17, 2020 4:55 am

(Of course, it should always work whether you delete the rests or not (and what good are those rests?).)

User avatar
zuill
Posts: 3352
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.3.1
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by zuill » Thu Sep 17, 2020 5:18 am

I too always thought those rests were unnecessary. Whose idea was that? Is it some kind of eye candy?

Zuill
Windows 10, Finale 2011-v26.3.1
"When all is said and done, more is said than done."

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Thu Sep 17, 2020 5:40 am

If it's going to create something, replicating the the original note would be more useful, but I'm sure would be confusing.

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Setting up spacing to avoid "crowded measures"

Post by motet » Thu Sep 17, 2020 5:58 am

It was easy to find the opposite bug, that occurs if you delete the rests.

Try creating this measure with Simple entry.
0690.png
After you've entered the first sixteenth note and have set up for "3 current duration in the space of 2", delete the rests it creates.
0691.png
Now try to enter the final two sixteenths:
0692.png

User avatar
miker
Posts: 4542
Joined: Fri Mar 13, 2009 4:28 pm
Finale Version: Finale 26
Operating System: Mac

Re: Setting up spacing to avoid "crowded measures"

Post by miker » Thu Sep 17, 2020 2:13 pm

I consider those rests as placeholders, not eye candy. I would not like to see them go away.

I don't generally use the "Use Current" setting. If you set it up for the "actual" (3-16ths in the space of 2-16ths) there are no problems. But just to check, I set it up to "Use Current." Again, for me, no problems.

The ONLY configuration that didn't work was when I used different notes (3/16ths in 1-8th.) I agree with you all; this should not be a problem. But it is, so, until they figure it out (Hah!) set it up with the notes, not with the equivalent combined note.

Patient: "Doctor, it hurts when I do this."
Doctor: "Don't do that."
Finale 26 | SmartScorePro X2
Mac OS 10.13 High Sierra
Copyist for Barbershop Harmony Society

Post Reply