Measure number regions problem

General notation questions, including advanced notation, formatting, etc., go here.

Moderators: miker, Peter Thomsen

User avatar
motet
Posts: 3414
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Measure number regions problem

Post by motet » Thu Jan 26, 2017 11:52 pm

I'm trying to set up measure number regions in Finale 2014.5, something I've done dozens of times in previous versions. As you'll see below, beginning with region 3, it refuses to obey the Starting Number field, and the font suddenly switches to Maestro, even though it says it's Time New Roman 10 italic.

Am I screwed by a new bug? I'll attach a file in the next posting.
0073.png
0073.png (218.96 KiB) Viewed 6100 times

Re: Measure number regions problem

by Sponsor

Forum Sponsor
 

User avatar
motet
Posts: 3414
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Measure number regions problem

Post by motet » Thu Jan 26, 2017 11:53 pm

I deleted all regions and started over, and it seemed clear up. So, never mind, I guess. Mysterious!
Last edited by motet on Fri Jan 27, 2017 12:04 am, edited 2 times in total.

Anders Hedelin
Posts: 248
Joined: Wed Jan 11, 2017 1:34 am
Finale Version: Finale 26
Operating System: Windows

Re: Measure number regions problem

Post by Anders Hedelin » Sat Jan 28, 2017 3:32 am

Motet, I've encountered this issue too a couple of times. It's a bug evidently, but maybe a benign one, simply due to 'program fatigue'. I never had to delete and recreate the measure number regions though, just closing and reopening the document did it.
Finale 26.1
Windows 7 and 10

User avatar
motet
Posts: 3414
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Measure number regions problem

Post by motet » Sat Jan 28, 2017 5:05 am

I'll try that next time!

eduardo
Posts: 7
Joined: Thu Mar 30, 2017 9:27 am
Finale Version: finale 2025
Operating System: Mac

Re: Measure number regions problem

Post by eduardo » Wed Dec 27, 2017 7:40 am

I have the same problem with Final 25 and Final 2014 but I can not solve it in any way.
More help please.
Thanks in advance.

User avatar
Peter Thomsen
Posts: 5692
Joined: Fri Jul 25, 2003 6:47 pm
Finale Version: Finale v26.2
Operating System: Mac

Re: Measure number regions problem

Post by Peter Thomsen » Wed Dec 27, 2017 3:26 pm

eduardo wrote:… but I can not solve it in any way …
Please specify the steps you've already taken, so that we can rule out things.

Have you e. g.
- closed and re-opened the Finale document?
- deleted all the measure number regions, and started over?
- re-booted?
- tried with a fresh, new (empty, un-corrupted) document?
- tried trashing the Preferences file?
Mac OS X 10.14 (Mojave), Finale user since 1996

eduardo
Posts: 7
Joined: Thu Mar 30, 2017 9:27 am
Finale Version: finale 2025
Operating System: Mac

Re: Measure number regions problem

Post by eduardo » Wed Dec 27, 2017 5:43 pm

Peter Thomsen wrote:
eduardo wrote:… but I can not solve it in any way …
Please specify the steps you've already taken, so that we can rule out things.

Have you e. g.
- closed and re-opened the Finale document?
- deleted all the measure number regions, and started over?
- re-booted?
- tried with a fresh, new (empty, un-corrupted) document?
- tried trashing the Preferences file?
Thanks for your help.
I tried every suggestion you listed.
The problem seems unsolvable.
Final allows me to realize only one or two regions.
Any other suggestions .......?

User avatar
motet
Posts: 3414
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Measure number regions problem

Post by motet » Wed Dec 27, 2017 5:51 pm

Attach your file.

eduardo
Posts: 7
Joined: Thu Mar 30, 2017 9:27 am
Finale Version: finale 2025
Operating System: Mac

Re: Measure number regions problem

Post by eduardo » Thu Dec 28, 2017 12:34 pm

Thanks.
I resolved with measure Numbers plugin.

GeorgeSv
Posts: 1
Joined: Fri Feb 09, 2018 11:43 pm
Finale Version: 25
Operating System: Mac

Re: Measure number regions problem

Post by GeorgeSv » Sat Feb 10, 2018 2:20 pm

I encountered the same problem in my Finale 25 and none of the suggestions helped until I added all the necessary regions all at the same time. I used to add and number one region at a time (add a region-number it, add another one-number it) and could not get beyond two regions. Now if I add 1, 2, 3, 4 regions and then number them in succession it works fine. I hope that I explained it well enough and that it will help.

fcopaja
Posts: 16
Joined: Thu Feb 09, 2017 6:35 pm
Finale Version: 2014
Operating System: Mac

Re: Measure number regions problem

Post by fcopaja » Wed Apr 25, 2018 2:04 pm

Hello, I'm also using Finale 25 on a Mac, and this issue is present too.
I've already got through all tips: erasing all regions, recreating as many as necessary an then modify ranges, checking Preferences->View->Display Actual Measure Numbers, closing-opening the file and Finale, etc., to no avail...
I also tried a new fresh default document to try again, attached to this post. The measure number for the second ending repeat should be 21, not 24...
Any new advices?

Felipe Copaja
Attachments
test.musx
(84.4 KiB) Downloaded 55 times

User avatar
zuill
Posts: 2768
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.2
Operating System: Windows

Re: Measure number regions problem

Post by zuill » Wed Apr 25, 2018 3:57 pm

I tested your file and deleted the regions, then reapplied them. It seems to be correct now. Maybe there's something buggy with Mac that Win doesn't seem to have.

Zuill
Windows 7, Finale 2011-v26.2
"When all is said and done, more is said than done."

fcopaja
Posts: 16
Joined: Thu Feb 09, 2017 6:35 pm
Finale Version: 2014
Operating System: Mac

Re: Measure number regions problem

Post by fcopaja » Wed Apr 25, 2018 6:03 pm

zuill wrote:Maybe there's something buggy with Mac
That would really be disastrous. I'm working on a large scale piece with multiple sections and measure regions. Text tool shall be then...

User avatar
zuill
Posts: 2768
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.2
Operating System: Windows

Re: Measure number regions problem

Post by zuill » Wed Apr 25, 2018 7:00 pm

I just tested a fresh document with your settings and everything worked as expected.

Did you say you had trashed your preferences and still have the problem?

Zuill
Windows 7, Finale 2011-v26.2
"When all is said and done, more is said than done."

User avatar
motet
Posts: 3414
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Measure number regions problem

Post by motet » Wed Apr 25, 2018 9:22 pm

Doing measure numbers with the text tool would be a mistake.

fcopaja
Posts: 16
Joined: Thu Feb 09, 2017 6:35 pm
Finale Version: 2014
Operating System: Mac

Re: Measure number regions problem

Post by fcopaja » Wed Apr 25, 2018 9:56 pm

Zuill and all, problem partially solved.
Though still a bug, when I clicked in the Style combo box, in the measure region definition, then the "Display As" showed the correct numbering and so did in the score. It didn't matter selecting a style, just clicking on it did the trick...

Thanks again.
Felipe

jbearch
Posts: 15
Joined: Mon Feb 13, 2012 1:43 pm
Finale Version: Finale 25
Operating System: Windows

Re: Measure number regions problem

Post by jbearch » Sun Jul 29, 2018 5:10 pm

I just encountered this problem today for the first time. It is driving me nuts. Finale 25 (Win 10) just won't accept page number 1 for different regions.
I have:
Restarted Finale and the file
Rebooted the computer
Deleted the regions and added them new
Started a new document fresh

Nothing works.
I would like to try fcopaja's solution but I don't understand it. What is the Style combo box? Eduardo solved it with the measure numbers plugin but I don't know what to try to get that to work. None of the items in the plug in menu point to measure regions. Motet also mentions Finale changing the font of the measure numbers in all regions after the first one. This happens to me too and causes so much work to change every font back to Times Roman. This must be a very serious bug. So far all solutions I have tried from the forum have not corrected the problem.
Jeff

User avatar
motet
Posts: 3414
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Measure number regions problem

Post by motet » Sun Jul 29, 2018 5:18 pm

Can you attach your file?

User avatar
motet
Posts: 3414
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Measure number regions problem

Post by motet » Sun Jul 29, 2018 5:26 pm

By "Style combo box" he or she must have meant this:
0676.png
0676.png (19.22 KiB) Viewed 4484 times
What a bizarre feature, by the way (to select anything but 1,2,3,4). I wonder if anyone uses it.

Let us know if that fixes it!

jbearch
Posts: 15
Joined: Mon Feb 13, 2012 1:43 pm
Finale Version: Finale 25
Operating System: Windows

Re: Measure number regions problem

Post by jbearch » Tue Aug 07, 2018 3:31 pm

I sent the file to Finale support and Kevin corrected it on his computer and sent it back. I couldn't do that although I tried everything suggested on this forum. I am sure it's a bug. Kevin even analyzed my computer information and could find nothing wrong there. These guys are great and so helpful. But there are maybe some things that even they can't solve if the program is at fault. So in Finale 25 we just might have to live with this for awhile. The problem of the font changing to Maestro in regions after the first one is another thing that is annoying and seems to be persistent. But at least that can be corrected. Just more work.

Jeffrey

mdriscoll
Posts: 8
Joined: Wed Nov 02, 2011 2:26 am
Finale Version: 2012

Re: Measure number regions problem

Post by mdriscoll » Sun Dec 09, 2018 2:25 pm

I'm not sure if the problem I am experiencing is the same as the previous posters, but what I am seeing is definitely a bug. See the attached Finale 25 file I created. I made three measure number regions, which cover mm. 1-54, 55-146 (displayed as 1-92), and 147-200 (displayed as 1-54). If you look at the file in Page View, the numbers display correctly. If you look at the measure numbers that appear in the region above each measure in either Scroll View or Studio View, however, you'll see that in the second region does not display correctly beginning at m. 54 of the second region. In other words, it displays as
1:1
1:2
...
1:53
1:54
2:1
2:2
...
2:53
2:54
55
56
...
91
92
3:1
3:2

So starting at m. 55 of the second region, it no longer displays the "2" that shows that it's the second region. The starting location of this display error appears to be connected to the length of the first region. For example, the first region in my example ended at m. 54 and the display error in the second region begins after m. 54.
Attachments
scroll view bug.musx
(154.74 KiB) Downloaded 38 times

User avatar
motet
Posts: 3414
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Measure number regions problem

Post by motet » Sun Dec 09, 2018 5:11 pm

This is normal. It displays the region number only when it's needed, or in other words not at the end of the longest region. I don't like it either, but that's the way it's always worked.

User avatar
N Grossingink
Posts: 1221
Joined: Mon Dec 19, 2016 2:50 pm
Finale Version: 2012, 25.3
Operating System: Mac

Re: Measure number regions problem

Post by N Grossingink » Sun Dec 09, 2018 5:21 pm

I deleted the measure regions in your file and re-did them using the JW Measure Numbers plugin. Now, all measure numbers show the region number, as you'd like (see attached). It's obvious that the plugin accesses information in the software at a different level to produce the expected result. I'd suggest you download the plugin (free) and use it.

https://www.finaletips.nu/index.php/download

N.
Attachments
scroll view bug fix.musx
(154.25 KiB) Downloaded 38 times
N. Grossingink
Department of Public Works Music Engraving Inspector - Milwaukee, WI


Mac Mini 2014 2.6 Ghz, 8Gb RAM
OSX 10.12.6
Finale 2012c & 25.5

User avatar
motet
Posts: 3414
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Measure number regions problem

Post by motet » Sun Dec 09, 2018 7:16 pm

I think all that the plug-in did to achieve this was to give the last region a large ending number, past the end of the file. That way, every defined number attached to a real measure is less than that large maximum, so the region will always be shown. I just tried it on the original without the plug-in and without deleting and recreating anything and it works (file attached).

I will do this from now on! Thank you, N. and JW.
Attachments
scroll view bug no JW.musx
(111.25 KiB) Downloaded 40 times

User avatar
motet
Posts: 3414
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Measure number regions problem

Post by motet » Sun Dec 09, 2018 7:44 pm

I just tried JW Measure Number Regions on the default document by deleting the defaukt region and the creating these three

| 1:1-2 | 2:1-2 | 3:1-27 |

and region 3 from measure 3 on doesn't show the region number, so I think the plug-in stumbled onto the solution in the file above by accident, due to the fact that the the default Finale creates goes up to 999 even though there are only 31 measures in the file. You must not have deleted the last one, N. The situation here can be fixed by making region 3 longer.

Post Reply