Layer 2 doesn't align with layer 1 after pasting

General notation questions, including advanced notation, formatting, etc., go here.

Moderators: miker, Peter Thomsen

dpm39560
Posts: 4
Joined: Thu May 28, 2015 6:04 pm
Finale Version: 2014
Operating System: Windows

Layer 2 doesn't align with layer 1 after pasting

Post by dpm39560 » Mon Aug 20, 2018 1:32 am

I had to copy an entire score into a new document, from Finale 2007 to version 25. When I pasted the percussion line, it was all messed up, so I had to use Utilities > Transpose Percussion Notes to get the notes to the right lines/instruments, with the snare drum on layer 1 in the second space down, and the bass drum in layer 2 in the bottom space.

So far, so good. ...EXCEPT...

...the bass drum notes consistently line up about 1.5 notehead widths to the right of where they would be if they aligned with the snare drum notes. Here is a JPG screenshot of what this misalignment looks like:
Layer2Misalign.jpg
Does anyone have a clue why this happened? Better yet, does anyone know of a way to fix this without having to delete and re-enter the entire 135-measure percussion line from scratch?

Thanks in advance for any help you can offer.

David in Mississippi

Re: Layer 2 doesn't align with layer 1 after pasting

by Sponsor

Forum Sponsor
 

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Layer 2 doesn't align with layer 1 after pasting

Post by motet » Mon Aug 20, 2018 1:35 am

This rings a bell. I'm guessing the red notes were on the middle line originally, which is why they're offset. There is a remedy involving changing the spacing options temporarily. Perhaps Zuill will remember.

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Layer 2 doesn't align with layer 1 after pasting

Post by motet » Mon Aug 20, 2018 1:43 am

Set Document Options / Manual Positioning to Clear, then respace. Then set Document Options / Manual Positioning back to what it was.

Vaughan
Posts: 267
Joined: Wed May 12, 2010 2:50 pm
Finale Version: Finale 25
Operating System: Mac

Re: Layer 2 doesn't align with layer 1 after pasting

Post by Vaughan » Mon Aug 20, 2018 9:53 am

This is actually a shortcoming in Finale. Notes a second apart are offset correctly, but if Manual Positioning is set to Incorporate or Ignore, transposing the offset notes won't reposition them properly. As Motet said, setting MP to Clear will take care of the problem but it will also undo any manual positioning you've done elsewhere. The upshot of all this is that using Finale efficiently necessitates a good workflow. In this case, it means that when entering notes, set Manual Positioning to Clear and perhaps even turn on Automatic Music Spacing in Preferences (with Automatic Update Layout turned on at ALL times!). Then, only after having entered articulations, expressions, smart shapes and lyrics, turn off Automatic Music Spacing, set Manual Positioning to Incorporate, and start tweaking and working on the layout.
Vaughan

Finale 3.2 - 26, Sibelius 4 - 7, Dorico 2.2
Tobias Giesen's plugins, full version, Robert Patterson plugins, Jari's plugins
MacOS 10.14.2
MacPro (2016) 16 GB, MacBookPro (2018) 16 GB

Amsterdam

dpm39560
Posts: 4
Joined: Thu May 28, 2015 6:04 pm
Finale Version: 2014
Operating System: Windows

Re: Layer 2 doesn't align with layer 1 after pasting

Post by dpm39560 » Mon Aug 20, 2018 11:24 am

motet wrote:Set Document Options / Manual Positioning to Clear, then respace. Then set Document Options / Manual Positioning back to what it was.
This was the correct solution, but it was incomplete. Through another forum, I heard that I needed to press <4> on my keyboard.

So what I did was go to Document > View Active Layer Only, then used the above menu item to set MP to clear, THEN pressed <4> on the keyboard, and that fixed the issue.

After fixing the issue, I reversed the steps, turning MP back to IGNORE and viewing all layers, and the part looks as it should now.

Thanks to everyone for their inputs.

Vaughan
Posts: 267
Joined: Wed May 12, 2010 2:50 pm
Finale Version: Finale 25
Operating System: Mac

Re: Layer 2 doesn't align with layer 1 after pasting

Post by Vaughan » Mon Aug 20, 2018 11:42 am

I answered this in the 'other' forum:

There are keyboard strokes for many of Finale's functions and most of us have created others via the OS and/or a macro program. The function being referred to here is Utilities/Music Spacing/Apply Note Spacing to Current Part/Score. If you look there, you'll see the shortcut listed. Surely you must have seen this; I don't believe it has changed (much) since 1995. If you don't have Automatic Music Spacing (in Preferences) selected, it's the only way you'll get Finale to space the music. (There's also beat spacing, activated by pressing 5.)

P.S. You didn't have to select 'View Active Layer Only' to accomplish this, BTW, so Motet's advice wasn't incomplete.
Vaughan

Finale 3.2 - 26, Sibelius 4 - 7, Dorico 2.2
Tobias Giesen's plugins, full version, Robert Patterson plugins, Jari's plugins
MacOS 10.14.2
MacPro (2016) 16 GB, MacBookPro (2018) 16 GB

Amsterdam

User avatar
zuill
Posts: 3352
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.3.1
Operating System: Windows

Re: Layer 2 doesn't align with layer 1 after pasting

Post by zuill » Mon Aug 20, 2018 2:00 pm

Since there are often times when I only want to clear positioning for certain measures (even certain notes in a specific layer, as in this case), my first choice for this is the JW Change plugin. I rarely need to use the document options/spacing setting to clear this kind of spacing situation.

Zuill
Windows 10, Finale 2011-v26.3.1
"When all is said and done, more is said than done."

User avatar
motet
Posts: 4561
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Layer 2 doesn't align with layer 1 after pasting

Post by motet » Mon Aug 20, 2018 4:15 pm

dpm39560 wrote:
motet wrote:Set Document Options / Manual Positioning to Clear, then respace. Then set Document Options / Manual Positioning back to what it was.
This was the correct solution, but it was incomplete. Through another forum, I heard that I needed to press <4> on my keyboard.
The 4 key is what I meant by "respace." Sorry--I assumed you knew how to do that.

Post Reply