"Hide Empty Staves" not working

General notation questions, including advanced notation, formatting, etc., go here.

Moderators: miker, Peter Thomsen

Post Reply
Aaronjw
Posts: 3
Joined: Fri Oct 19, 2018 4:27 pm
Finale Version: 25
Operating System: Windows

"Hide Empty Staves" not working

Post by Aaronjw » Fri Oct 19, 2018 4:35 pm

Working on a piece of music for organ. The second half of the piece uses all three staves (right hand, left hand, pedal for those unfamiliar with organ notation), but the first half is only right hand and left hand, so I'd like to hide the pedal staff for the first couple of pages. However, when I select the staff and try the "Hide Empty Staves" button, nothing happens. I've changed the Organ group attributes to "When Hiding Empty Staves: Hide Normally," and I've set the pedal staff attributes to "Allow hiding when empty," but hide empty staves still has no effect at all. I've googled around and couldn't find any solution other than these two.

Any thoughts?

Re: "Hide Empty Staves" not working

by Sponsor

Forum Sponsor
 

User avatar
michelp
Posts: 1550
Joined: Fri Jul 25, 2003 3:35 pm
Finale Version: 25.5, 2014.5
Operating System: Mac

Re: "Hide Empty Staves" not working

Post by michelp » Fri Oct 19, 2018 4:41 pm

Make sure that the staff is really empty when inactive (no "real" rests).
Michel
MacOsX 10.11.6, Finale 25.5, 2014.5, Mac Mini Intel Dual Core i7 3Ghz, 16 Go Ram. Azerty kb. Full TGTools. MOTU Midi Express XT USB, Roland Sound Canvas SC-88vl, MOTU Audio Express. 2 monitors (27' pivot, 24')

Aaronjw
Posts: 3
Joined: Fri Oct 19, 2018 4:27 pm
Finale Version: 25
Operating System: Windows

Re: "Hide Empty Staves" not working

Post by Aaronjw » Fri Oct 19, 2018 5:22 pm

That doesn't seem to be the problem; even if I make a brand new experimental document, put a few notes in the LH and RH staves, and put nothing in the pedal part, it still doesn't work.

I then tried adding another staff (a soprano voice) to my experimental document, and it behaved as it should when I tried to hide it, so it seems like there's some kind of issue with the group attributes. But the group is set to "hide normally," so I don't know what the problem could actually be.

User avatar
michelp
Posts: 1550
Joined: Fri Jul 25, 2003 3:35 pm
Finale Version: 25.5, 2014.5
Operating System: Mac

Re: "Hide Empty Staves" not working

Post by michelp » Fri Oct 19, 2018 5:28 pm

You could submit the file here (or an excerpt).
Michel
MacOsX 10.11.6, Finale 25.5, 2014.5, Mac Mini Intel Dual Core i7 3Ghz, 16 Go Ram. Azerty kb. Full TGTools. MOTU Midi Express XT USB, Roland Sound Canvas SC-88vl, MOTU Audio Express. 2 monitors (27' pivot, 24')

Bill Stevens
Posts: 190
Joined: Wed Dec 28, 2016 1:37 pm
Finale Version: 26.2
Operating System: Mac

Re: "Hide Empty Staves" not working

Post by Bill Stevens » Fri Oct 19, 2018 5:29 pm

Probably the organ is set up as a group that doesn't allow hiding staves. That would be typical for keyboard instruments.

You'll need to select the group and edit, make sure the instrument is set to "All Staves" and then "Hide Normally". I just tried it and it works.

Bill
Version 26.2.1 / Mac OS 10.15 Catalina
Finale user since the beginning.

Aaronjw
Posts: 3
Joined: Fri Oct 19, 2018 4:27 pm
Finale Version: 25
Operating System: Windows

Re: "Hide Empty Staves" not working

Post by Aaronjw » Fri Oct 19, 2018 5:37 pm

Attaching the document to this message.

Bill: You mean in the "group attributes"? As I said in my first post, I did try setting the group attributes to "hide normally" when hiding empty staves. It changed nothing.

EDIT-- Submitted my post before I saw you edited yours with more info. What do you mean by "instrument is set to 'All Staves'"? Maybe I've missed that.

EDIT 2-- Found it! That was indeed the problem! Thanks so much!

Edit 3-- I'm deleting the document from the post for security's sake.

User avatar
motet
Posts: 3478
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: "Hide Empty Staves" not working

Post by motet » Mon Oct 22, 2018 7:31 am

michelp wrote:Make sure that the staff is really empty when inactive (no "real" rests).
Real rests no longer interfere with hiding empty staves--even if they contain fermatas (a nice feature). I think this change for the better occurred when "Optimize" was replaced by "Hide empty staves."
Last edited by motet on Mon Oct 22, 2018 8:45 pm, edited 1 time in total.

User avatar
michelp
Posts: 1550
Joined: Fri Jul 25, 2003 3:35 pm
Finale Version: 25.5, 2014.5
Operating System: Mac

Re: "Hide Empty Staves" not working

Post by michelp » Mon Oct 22, 2018 10:17 am

You are correct, motet (verified in 2011, 2012, 2014d, 2014.5, 25.5 Mac). Since the appearance of "Hide Empty Staves" in the Staff menu.
Old habits have a tendency to persist. Thanks for the reminder.
Michel
MacOsX 10.11.6, Finale 25.5, 2014.5, Mac Mini Intel Dual Core i7 3Ghz, 16 Go Ram. Azerty kb. Full TGTools. MOTU Midi Express XT USB, Roland Sound Canvas SC-88vl, MOTU Audio Express. 2 monitors (27' pivot, 24')

User avatar
RimasG
Posts: 7
Joined: Mon Jan 02, 2017 9:24 am
Finale Version: Finale 26
Operating System: Windows

Re: "Hide Empty Staves" not working

Post by RimasG » Mon Oct 22, 2018 10:53 am

Easiest, simplest and reliable way for me to hide empty staves from group - delete group, hide unnecessary staves and create group again. This way work for me without complaints.

leonardociampa
Posts: 5
Joined: Wed Oct 09, 2019 2:10 pm
Finale Version: Finale 2014
Operating System: Windows

Re: "Hide Empty Staves" not working

Post by leonardociampa » Wed Oct 09, 2019 2:20 pm

I had the same problem yesterday. And yes, "all staves" is the solution. (Thank you, Forum!) However, I wanted to clarify one detail that wasn't obvious. You click on the group name and right-click to get to Group Attributes. (That part was clear.) But then, when you get to the Group Attributes window, there is a pull down menu in the upper left corner. There are two options: "Organ" and "Organ (all staves)." You want the second one.

Nick Mazuk
Posts: 140
Joined: Tue Jul 03, 2018 12:29 am
Finale Version: Finale 26
Operating System: Mac

Re: "Hide Empty Staves" not working

Post by Nick Mazuk » Wed Oct 09, 2019 8:36 pm

There's also a staff style called "Force Hide Staff (Collapse)" that you could try on the organ staff.
Nick

Post Reply