Noteperformer causing Aria delay

Discuss playback problems, including VST, Garritan, MIDI, etc.

Moderators: Peter Thomsen, miker

Pontus Hambe
Posts: 13
Joined: Mon May 10, 2021 8:58 pm
Finale Version: Finale 25
Operating System: Windows

Post by Pontus Hambe » Sun May 16, 2021 1:59 pm

When Noteperformer is "active" in Finale 26, it is impossible to play whith the midi keyboard on Aria player. There is the same old one second delay. If I empty the NP bank in the VST dialogue page then Aria player works again. This problem is the same whether I play on my midi keyboard or directly on the virtual piano in Aria player. Finale compensate the latency on playback so it is possible to have NP and GPO playing back simultaneously. The strange thing is that it is possible to play on any loaded NP sound whithout latency using a midi keyboard. NP is awesome but GPO has many very nice samples that I rather use when I am composing or arranging (playing on my keyboard).

Even if you do not have a solution it would be very helpful to now if this is a known issue or if it´s something wrong in my set up. I have the latest versions of NP and Finale.

Thank you/Pontus

Fin26, GPO4 + 5, Noteperformer
Fin 26
Noteperformer
GPO4
GPO5
Win 10


BurtGoldstein
Posts: 87
Joined: Sat Apr 15, 2023 8:32 pm
Finale Version: 27
Operating System: Mac

Post by BurtGoldstein » Tue Jun 11, 2024 7:40 pm

I have the same problem! Using Finale 27.4 and NotePerformer 4.40.
has no solution been found in three years?

Aria's Settings show many settings for RAM and streaming. (see attachment)

How can we up the RAM given to Aria under "Performance Monitoring?" Wouldn't that help?

I could move "precaching" up to 128k But streaming is 0 and allocation for the Steinway I have loaded in about 10 MB. I can't chang either number on the Settings page - is there another place to change these?

1 GB of RAM is allocated to the Player!
Attachments
ARIA has delay with NotePerformer loaded.jpg

BuonTempi
Posts: 1335
Joined: Fri Aug 20, 2010 8:59 am
Finale Version: Finale 27
Operating System: Mac

Post by BuonTempi » Wed Jun 12, 2024 8:56 am

Make sure you report the issue to MakeMusic.

BurtGoldstein
Posts: 87
Joined: Sat Apr 15, 2023 8:32 pm
Finale Version: 27
Operating System: Mac

Post by BurtGoldstein » Wed Jun 12, 2024 5:40 pm

The soluton was too simple for me to find!

Simply increase the MAX Engine RAM Allocator (a bit at a time until latency is gone)
Decrease "Inst. Disk Pre-Caching" (a bit at a time until latency s gone)

The "Performance Monitoring" filed are,as I might have accepted if I read the name of the section! - NOT changable, even to they look relevant!

Post Reply