Finale does not release audio stream - exclusive mode (?)

Discuss technical issues with keyboards, sound, video cards, etc.

Moderators: miker, Peter Thomsen

User avatar
Edgar5
Posts: 2
Joined: Sun Mar 10, 2019 11:40 pm
Finale Version: 26
Operating System: Windows

Finale does not release audio stream - exclusive mode (?)

Post by Edgar5 » Mon Mar 11, 2019 11:26 pm

New install of Finale 25. Windows 10 1803. ASUS Prime X299-Deluxe Motherboard out to Soundcraft Signature 12MTK mixer via USB.

Problem 1: Even though I have gone into the Sound settings and turned off "Exclusive Mode" for my mixer… If I have any other source playing sound (e.g. MediaMonkey, Audacity, VLC etc.) when I launch Finale, the sound stops coming through my mixer.

Problem 2: After I exit Finale, no other sound source is allowed access to the mixer. I must reboot to free the audio stream.

I almost never use Finale to produce sound; it is used almost exclusively to create clean copies of handwritten charts.

Is there some setting in Finale which will tell it play nice with other sound sources?

Edgar5

Re: Finale does not release audio stream - exclusive mode (?)

by Sponsor

Forum Sponsor
 

User avatar
motet
Posts: 3478
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Finale does not release audio stream - exclusive mode (?

Post by motet » Tue Mar 12, 2019 1:23 am

Not that I've found. If you find a solution, please let us know.

User avatar
zuill
Posts: 2802
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.2
Operating System: Windows

Re: Finale does not release audio stream - exclusive mode (?

Post by zuill » Tue Mar 12, 2019 2:53 am

Either ASIO or Rewire might be involved here. Are you using either of those?

Zuill
Windows 7, Finale 2011-v26.2
"When all is said and done, more is said than done."

User avatar
motet
Posts: 3478
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Finale does not release audio stream - exclusive mode (?

Post by motet » Tue Mar 12, 2019 5:20 am

On my system it's hard to tell. What's the solution if so?

User avatar
zuill
Posts: 2802
Joined: Sat Dec 10, 2016 9:35 pm
Finale Version: Finale 2011-v26.2
Operating System: Windows

Re: Finale does not release audio stream - exclusive mode (?

Post by zuill » Tue Mar 12, 2019 5:25 am

I was referring mostly to the OP, as Finale 25 has both. I have not used Rewire, so I have never turned it on. In audio settings, I use direct sound, not ASIO. ASIO has caused me problems in the past.

Zuill
Windows 7, Finale 2011-v26.2
"When all is said and done, more is said than done."

User avatar
motet
Posts: 3478
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Finale does not release audio stream - exclusive mode (?

Post by motet » Tue Mar 12, 2019 6:24 am

Well, now F2014.5 won't play at all. The playback cursor hangs in the first bar. Scrubbing doesn't work. 2011 works fine. The people in MM technical support throw up their hands.

I'm getting near the end of my rope with Finale. Finally have a 64-bit machine, so am able to run Dorico now.
Last edited by motet on Tue Mar 12, 2019 6:31 am, edited 1 time in total.

User avatar
motet
Posts: 3478
Joined: Tue Dec 06, 2016 8:33 pm
Finale Version: 2014.5,2011,2005
Operating System: Windows

Re: Finale does not release audio stream - exclusive mode (?

Post by motet » Tue Mar 12, 2019 6:30 am

Under Finale's Audio Setup the only choice is Realtek ASIO.

User avatar
Edgar5
Posts: 2
Joined: Sun Mar 10, 2019 11:40 pm
Finale Version: 26
Operating System: Windows

Re: Finale does not release audio stream - exclusive mode (?

Post by Edgar5 » Tue Mar 12, 2019 4:40 pm

zuill wrote:Either ASIO or Rewire might be involved here. Are you using either of those?
it seems that ASIO was set as the default. I tried DirectSound but got error code 7. I tried WASAPI and resolve the issue of Finale hijacking the Audio Stream, but Finale produced no sound output. I retried ASIO and got sound output but Finale hijacking the Audio Stream. I retried DirectSound and this time did not get an error code and everything works just fine* - Finale DID NOT hijack the Audio Stream, with MediaMonkey playing in the background I was able to hear piano notes entered and the score played.

* While Finale would play piano it would not produce any sound for a simple bass drum line. I can live with this!

My thanks to zuill for pointing me in the right direction!

Post Reply