2014.5 not authorizing

Discuss technical issues with keyboards, sound, video cards, etc.

Moderators: Peter Thomsen, miker

tanyaviola
Posts: 35
Joined: Fri Oct 24, 2008 11:41 pm

2014.5 not authorizing

Post by tanyaviola » Tue Dec 31, 2019 3:10 pm

I just got a new iMac (with Mojave) and I'm trying to authorize Finale and it just keeps crashing. I went online to my account and de-authorized my old mac. This version was working fine on my old Mac (also with Mojave) so I'm not sure what's going on. I really need to use it....help!

T.
Finale 2014.5, OS Mojave
2019 iMac 3.7 GHz Intel Core i5
40 GB RAM

Re: 2014.5 not authorizing

by Sponsor

Forum Sponsor
 

User avatar
miker
Posts: 5076
Joined: Fri Mar 13, 2009 4:28 pm
Finale Version: Finale 26
Operating System: Mac

Re: 2014.5 not authorizing

Post by miker » Tue Dec 31, 2019 4:37 pm

2014.5 won't install on Mojave. You need to upgrade. (It may have run on your old computer, if it was installed when you upgraded.)

Finale 2014.5 for Macintosh®

OS X 10.8 – 10.12
Intel Core 2 Duo or better, Intel i3 and above recommended
2 GB of RAM, 4 GB or above recommended
800×600 minimum monitor resolution, between 1366×768 and 1920×1080 recommended
Internet connection for download install or DVD-ROM drive for DVD install
1GB hard drive space required for software and user manual with an additional 2GB hard drive space is required for Garritan Instruments for Finale
Finale 26.3 | SmartScorePro 64
Mac OS 11.4 Big Sur
Copyist for Barbershop Harmony Society

Post Reply